Back to CVE records
High 7.4Published Apr 16, 2026

CVE-2026-33804@fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option

Updated under an hour ago ()

Does this affect you?

It affects @fastify/middie and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.

CVSS
7.4 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-436
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
openjs
NVD analysis
Analyzed
Record last updated
Apr 16, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
@fastify/middie @fastify/middie
fastify_middie:fastify_middie (from the name)
before 9.3.2; 9.3.2 not affected
CNA record
fastify fastify/middie
fastify:fastify/middie
before 9.3.2
NVD

References

  • mitigation, vendor-advisory
  • vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.