Back to CVE records
Medium 5.9Published Apr 3, 2026

CVE-2026-34052LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)

Updated under an hour ago ()

Does this affect you?

It affects jupyterhub ltiauthenticator and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

CVSS
5.9 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-401, CWE-770
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 6, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
jupyterhub ltiauthenticator
jupyterhub:ltiauthenticator (from the name)
before 1.6.3
CNA record
jupyter lti_jupyterhub_authenticator
jupyter:lti_jupyterhub_authenticator
before 1.6.3
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.