Back to CVE records
High 7.1Published Mar 30, 2026

CVE-2026-34060Ruby LSP has arbitrary code execution through branch setting

Updated under an hour ago ()

Does this affect you?

It affects Shopify ruby-lsp and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

CVSS
7.1 HIGH (v4.0, CNA)CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-94
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 2, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Shopify ruby-lsp
shopify:ruby_lsp (from the name)
before 0.26.9
CNA record
Shopify Shopify.ruby-lsp
shopify:shopify.ruby_lsp (from the name)
before 0.10.2
CNA record
shopify ruby_lsp
shopify:ruby_lsp
before 0.10.2; before 0.26.9
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.