Back to CVE records
Medium 6.9Published Mar 31, 2026

CVE-2026-34400alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API

Updated under an hour ago ()

Does this affect you?

It affects alerta and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.

CVSS
6.9 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-89
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 3, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
alerta alerta
alerta:alerta (from the name)
before 9.1.0
CNA record
alerta_project alerta
alerta_project:alerta
before 9.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.