Back to CVE records
Medium 5.1Published Apr 6, 2026

CVE-2026-34951Reflected XSS in footer.php in Workbench Allows Attackers to Hijack Authenticated Sessions

Updated under an hour ago ()

Does this affect you?

It affects forceworkbench and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Workbench is a suite of tools for administrators and developers to interact with Salesforce.com organizations via the Force.com APIs. Prior to 65.0.0, Workbench contains a reflected cross-site scripting vulnerability via the footerScripts parameter, which does not sanitize user-supplied input before rendering it in the page response. Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Workbench allows XSS Targeting Error Pages. This vulnerability is fixed in 65.0.0.

CVSS
5.1 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 7, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
forceworkbench forceworkbench
forceworkbench:forceworkbench (from the name)
before 65.0.0
CNA record
salesforce workbench
salesforce:workbench
before 65.0.0
NVD

References

  • x-refsource-confirm, vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.