Back to CVE records
Critical 9.1Published Apr 6, 2026

CVE-2026-35174Chyrp Lite has a Path Traversal to Remote Code Execution

Updated under an hour ago ()

Does this affect you?

It affects xenocrat chyrp-lite and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Chyrp Lite is an ultra-lightweight blogging engine. Prior to 2026.01, a path traversal vulnerability exists in the administration console that allows an administrator or a user with Change Settings permission to change the uploads path to any folder. This vulnerability allows the user to download any file on the server, including config.json.php with database credentials and overwrite critical system files, leading to remote code execution. This vulnerability is fixed in 2026.01.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-22, CWE-73, CWE-434
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 7, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
xenocrat chyrp-lite
xenocrat:chyrp_lite (from the name)
before 2026.01
CNA record
chyrplite chyrp_lite
chyrplite:chyrp_lite
before 2026.01
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.