Back to CVE records
Medium 4.1Published Apr 6, 2026

CVE-2026-35177Path traversal issue with zip.vim in Vim

Updated under an hour ago ()

This data is behind schedule: last updated Oct 27, 2026, 10:23 AM ET. We are working on it.Behind: National Vulnerability Database (CVE API 2.0, CPE API 2.0).

Does this affect you?

It affects vim. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.

CVSS
4.1 MEDIUM (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:L
Weakness (CWE)
CWE-22
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 7, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
vim vim
vim:vim (from the name)
before 9.2.0280
CNA record
vim vim
vim:vim
before 9.2.0280
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.