Back to CVE records
High 7.2Published Apr 8, 2026

CVE-2026-35476InvenTree Affected by Privilege Escalation via API

Updated under an hour ago ()

Does this affect you?

It affects InvenTree and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, a non-staff authenticated user can elevate their account to a staff level via a POST request against their user account endpoint. The write permissions on the API endpoint are improperly configured, allowing any user to change their staff status. This vulnerability is fixed in 1.2.7 and 1.3.0.

CVSS
7.2 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness (CWE)
CWE-285
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
inventree InvenTree
inventree:inventree (from the name)
before 1.2.7
CNA record
inventree_project inventree
inventree_project:inventree
through 1.2.6
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.