Back to CVE records
Medium 5.0Published Apr 8, 2026

CVE-2026-39881Vim Ex command injection in Vims NetBeans integration

Updated under an hour ago ()

Does this affect you?

It affects vim. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Vim is an open source, command line text editor. Prior to 9.2.0316, a command injection vulnerability in Vim's netbeans interface allows a malicious netbeans server to execute arbitrary Ex commands when Vim connects to it, via unsanitized strings in the defineAnnoType and specialKeys protocol messages. This vulnerability is fixed in 9.2.0316.

CVSS
5.0 MEDIUM (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:N
Weakness (CWE)
CWE-94
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 9, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
vim vim
vim:vim (from the name)
before 9.2.0316
CNA record
vim vim
vim:vim
before 9.2.0316
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.