CVE-2026-40352FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover
Updated under an hour ago ()
Does this affect you?
It affects labring FastGPT and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.
- CVSS
- 8.8 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-943
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Apr 20, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
labring FastGPT labring:fastgpt (from the name) | before 4.14.9.5 | CNA record |
fastgpt fastgpt fastgpt:fastgpt | before 4.14.9.5 | NVD |
References
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6x-refsource-confirm, exploit, vendor-advisory
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2dx-refsource-misc, patch
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5x-refsource-misc, product, release-notes
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.