Back to CVE records
High 7.1Published Jun 17, 2026

CVE-2026-40720WordPress Royal Elementor Addons Pro plugin < 1.7.1041 - Cross Site Scripting (XSS) vulnerability

Updated under an hour ago ()

Does this affect you?

It affects Royal Elementor Addons Pro. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Unauthenticated Cross Site Scripting (XSS) in Royal Elementor Addons Pro < 1.7.1041 versions.

CVSS
7.1 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Patchstack
NVD analysis
Deferred
Record last updated
Jun 17, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Royal Elementor Addons Royal Elementor Addons Pro
royal_elementor_addons:pro (from the name)
from n/a before 1.7.1041; fixed at 1.7.1041
CNA record

References

  • vdb-entry

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.