Back to CVE records
Medium 6.9Published Apr 21, 2026

CVE-2026-40944Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles

Updated under an hour ago ()

Does this affect you?

It affects oxia-db oxia. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.

CVSS
6.9 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-295
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Apr 22, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
oxia-db oxia
oxia_db:oxia (from the name)
before 0.16.2
CNA record

References

  • x-refsource-confirm

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.