Back to CVE records
High 8.7Published May 8, 2026

CVE-2026-41163bubblewrap vulnerable to privilege escalation in setuid mode via ptrace

Updated under an hour ago ()

Does this affect you?

It affects containers bubblewrap and 2 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-269
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Sep 1, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
containers bubblewrap
containers:bubblewrap (from the name)
from 0.11.0, < 0.11.2
CNA record
10
CISA ADP
4
CISA ADP

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.