Back to CVE records
High 7.7Published Apr 23, 2026

CVE-2026-41268Flowise: Flowise Parameter Override Bypass Remote Command Execution

Updated under an hour ago ()

Does this affect you?

It affects FlowiseAI Flowise. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

CVSS
7.7 HIGH (v3.0, CNA)CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
Weakness (CWE)
CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 23, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
FlowiseAI Flowise
flowiseai:flowise (from the name)
before 3.1.0
CNA record
flowiseai flowise
flowiseai:flowise
before 3.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.