Back to CVE records
High 7.1Published Apr 23, 2026

CVE-2026-41271Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains

Updated under an hour ago ()

Does this affect you?

It affects FlowiseAI Flowise and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

CVSS
7.1 HIGH (v3.0, CNA)CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
Weakness (CWE)
CWE-918
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Apr 23, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
FlowiseAI Flowise
flowiseai:flowise (from the name)
before 3.1.0
CNA record
FlowiseAI flowise-components
flowiseai:flowise_components (from the name)
before 3.1.0
CNA record
flowiseai flowise
flowiseai:flowise
before 3.1.0
NVD

References

  • x-refsource-confirm, exploit, vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.