CVE-2026-41501electerm has Command Injection Vulnerability via runLinux function
Updated under an hour ago ()
Does this affect you?
It affects electerm and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
- CVSS
- 9.8 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-77
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- May 8, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
electerm electerm electerm:electerm (from the name) | before 3.3.8 | CNA record |
electerm_project electerm electerm_project:electerm | before 3.3.8 | NVD |
References
- https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hqx-refsource-confirm, patch, vendor-advisory
- https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128eex-refsource-misc, patch
- https://github.com/electerm/electerm/releases/tag/v3.3.8x-refsource-misc, release-notes
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.