CVE-2026-41575th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability
Updated under an hour ago ()
Does this affect you?
It affects th30d4y IP and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.
- CVSS
- 6.1 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness (CWE)
- CWE-79, CWE-80
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- May 8, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
th30d4y IP th30d4y:ip (from the name) | from 1.0.1, < 2.0.1 | CNA record |
th30d4y w4nn4d13/ip th30d4y:w4nn4d13/ip | from 1.0.1 before 2.0.1 | NVD |
References
- https://github.com/th30d4y/IP/security/advisories/GHSA-j7wv-7j97-9qh9x-refsource-confirm, vendor-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.