Back to CVE records
Critical 9.8Published May 4, 2026

CVE-2026-42076Evolver: Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution

Updated under an hour ago ()

Does this affect you?

It affects EvoMap evolver. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

CVSS
9.8 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-78
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
May 5, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
EvoMap evolver
evomap:evolver (from the name)
before 1.69.3
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.