Back to CVE records
High 8.8Published May 13, 2026

CVE-2026-42266JupyterLab has an Extension Manager API/GUI Policy Discrepancy allowing 3rd party (malicious) extensions install via POST request.

Updated under an hour ago ()

Does this affect you?

It affects jupyterlab and 3 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

CVSS
8.8 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-88, CWE-602
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
Aug 28, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
jupyterlab jupyterlab
jupyterlab:jupyterlab (from the name)
from 4.0.0, < 4.5.7
CNA record
Red Hat Red Hat Migration Toolkit for Applications 8.2
redhat:migration_toolkit_applications
from 1784109883 not affected
CISA ADP
from 1787076778 not affected
CISA ADP
jupyter jupyterlab
jupyter:jupyterlab
from 4.0.0 before 4.5.7
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.