Back to CVE records
High 8.2Published May 12, 2026

CVE-2026-42268ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

Updated under an hour ago ()

Does this affect you?

It affects owasp-modsecurity ModSecurity and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

CVSS
8.2 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-191, CWE-248
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
May 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
owasp-modsecurity ModSecurity
owasp_modsecurity:modsecurity (from the name)
from 3.0.0, < 3.0.15
CNA record
owasp modsecurity
owasp:modsecurity
from 3.0.0 before 3.0.15
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.