Back to CVE records
High 7.5Published Jun 8, 2026

CVE-2026-42536Apache HTTP Server: mod_xml2enc heap overflow

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache HTTP Server and 8 other products. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Heap-based Buffer Overflow vulnerability in Apache HTTP Server with mod_xml2enc, xml2StartParse, and untrusted content This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

CVSS
7.5 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-122, CWE-120
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Modified
Record last updated
Sep 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache HTTP Server
apache_software_foundation:apache_http_server (from the name)
from 2.4.0 through 2.4.67
CNA record
Red Hat JBoss Core Services for RHEL 8
redhat:jboss_core_services
from 0:2.4.62-16.el8jbcs not affected
CISA ADP
from 0:2.4.63-13.el10_2.4 not affected
CISA ADP
from 0:2.4.63-1.el10_0.4 not affected
CISA ADP
from 0:2.4.57-11.el9_4.5 not affected
CISA ADP
from 0:2.4.62-4.el9_6.6 not affected
CISA ADP
from 2.4.68-1.hum1 not affected
CISA ADP
from 1786433656 not affected
CISA ADP
apache http_server
apache:http_server
from 2.4.0 before 2.4.68
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.