CVE-2026-42887Audiobookshelf: Stored Cross-Site Scripting in Login Page Custom Message
Updated under an hour ago ()
Does this affect you?
It affects advplyr audiobookshelf. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.
- CVSS
- 4.5 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- Weakness (CWE)
- CWE-79
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Deferred
- Record last updated
- May 12, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
advplyr audiobookshelf advplyr:audiobookshelf (from the name) | before 2.33.0 | CNA record |
References
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-cx29-ghq2-9cm4x-refsource-confirm
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.