Back to CVE records
Critical 9.4Published May 7, 2026

CVE-2026-43944electerm: dangerous code can be run through links or command line

Updated under an hour ago ()

Does this affect you?

It affects electerm and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

CVSS
9.4 CRITICAL (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Weakness (CWE)
CWE-20, CWE-94, CWE-829
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Modified
Record last updated
May 13, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
electerm electerm
electerm:electerm (from the name)
from 3.0.6, < 3.8.15
CNA record
electerm_project electerm
electerm_project:electerm
from 3.0.6 before 3.8.15
NVD

References

  • x-refsource-confirm, mitigation, patch, vendor-advisory
  • x-refsource-misc
  • x-refsource-misc, patch
  • x-refsource-misc, patch
  • x-refsource-misc, release-notes

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.