Back to CVE records
Low 2.3Published Jun 19, 2026

CVE-2026-44046Apache APISIX: wolf-rbac plugin Identity Spoofing

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache APISIX and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

CVSS
2.3 LOW (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
Weakness (CWE)
CWE-348
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Jun 22, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache APISIX
apache_software_foundation:apache_apisix (from the name)
from 1.2.0 through 3.16.0
CNA record
apache apisix
apache:apisix
from 1.2 before 3.17.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.