Back to CVE records
Critical 9.3Published May 14, 2026

CVE-2026-44212PrestaShop: Stored XSS executable in customer service view

Updated under an hour ago ()

Does this affect you?

It affects PrestaShop. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PrestaShop is an open source e-commerce web application. Prior to 8.2.6 and 9.1.1, there is a stored Cross-Site Scripting (XSS) vulnerability in the PrestaShop back-office Customer Service view. An unauthenticated attacker can submit the public Contact Us form with a malicious email address. The payload is stored in the database and executed when a back-office employee opens the affected customer thread, enabling session hijacking and full back-office takeover. This vulnerability is fixed in 8.2.6 and 9.1.1.

CVSS
9.3 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weakness (CWE)
CWE-79
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
May 15, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
PrestaShop PrestaShop
prestashop:prestashop (from the name)
before 8.2.6; from 9.0.0-alpha.1, < 9.1.1
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.