Back to CVE records
High 8.2Published May 26, 2026

CVE-2026-44728Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs

Updated under an hour ago ()

Does this affect you?

It affects babel and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.

CVSS
8.2 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-94, CWE-843
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
May 27, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
babel babel
babel:babel (from the name)
from 7.12.0, < 7.29.4; from 8.0.0-alpha.0, < 8.0.0-alpha.13
CNA record
@babel plugin-transform-modules-systemjs
babel:plugin_transform_modules_systemjs (from the name)
from 7.12.0, < 7.29.4; from 8.0.0-alpha.0, < 8.0.0-alpha.13
CNA record
babel babel
babel:babel
from 7.12.0 before 7.29.4; 8.0.0; 8.0.0; 8.0.0; 8.0.0; 8.0.0; 8.0.0; 8.0.0; and 6 more ranges
NVD

References

  • x-refsource-confirm, mitigation, vendor-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.