Back to CVE records
Critical 9.1Published May 13, 2026

CVE-2026-45158OPNsense: Command Injection via Attacker-Controlled DHCP Config

Updated under an hour ago ()

Does this affect you?

It affects opnsense core and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, unsanitized user input is passed to the DHCP configuration of the configured interface, which is processed by a shell script, allowing remote code execution as root on the underlying operating system. This vulnerability is fixed in 26.1.8.

CVSS
9.1 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-88
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
May 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
opnsense core
opnsense:core (from the name)
before 26.1.8
CNA record
opnsense opnsense
opnsense:opnsense
before 26.1.8
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.