Back to CVE records
Medium 5.3Published May 14, 2026

CVE-2026-45205Apache Commons Configuration: StackOverflowError for YAML input with cycles

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Commons Configuration and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

CVSS
5.3 MEDIUM (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness (CWE)
CWE-674
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
May 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Commons Configuration
apache_software_foundation:apache_commons_configuration (from the name)
from 2.2 before 2.15.0
CNA record
apache commons_configuration
apache:commons_configuration
from 2.2 before 2.15.0
NVD

References

  • patch, issue-tracking
  • vendor-advisory, mailing-list
  • mailing-list, third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.