Back to CVE records
Critical 10.0Published Jul 15, 2026

CVE-2026-463399Router: Unauthenticated Remote Code Execution via unprotected MCP custom plugin routes

Updated under an hour ago ()

Does this affect you?

It affects decolua 9router. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

9Router is an AI router & token saver. From 0.4.30 until 0.4.37, 9Router's src/proxy.js middleware did not protect /api/cli-tools/* and /api/mcp/*, allowing unauthenticated registration of customPlugins through src/app/api/cli-tools/cowork-settings/route.js and command execution through the MCP bridge. This vulnerability is fixed in 0.4.37.

CVSS
10.0 CRITICAL (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness (CWE)
CWE-78, CWE-306
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jul 16, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
decolua 9router
decolua:9router (from the name)
from 0.4.30, < 0.4.37
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.