Back to CVE records
Medium 5.6Published Jul 17, 2026

CVE-2026-46420setup-php: Command Injection in Repository-Derived PHP Version Resolution

Updated under an hour ago ()

Does this affect you?

It affects shivammathur setup-php. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

setup-php is a GitHub action to set up PHP with extensions, php.ini configuration, coverage drivers, and tools. From 2.25.0 prior to 2.37.1, shivammathur/setup-php resolves the PHP version from repository-controlled files such as .php-version, composer.lock through platform-overrides.php, and composer.json through config.platform.php, and insufficiently constrains those values before incorporating them into generated shell or PowerShell setup scripts, allowing command injection on a GitHub Actions runner when workflows such as pull_request_target check out attacker-controlled contents before invoking setup-php. This issue is fixed in version 2.37.1.

CVSS
5.6 MEDIUM (v3.1, CNA)CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness (CWE)
CWE-78
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jul 20, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
shivammathur setup-php
shivammathur:setup_php (from the name)
from 2.25.0, < 2.37.1
CNA record
shivammathur setup_php
shivammathur:setup_php
from 2.25.0 before 2.37.1
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.