Back to CVE records
High 8.9Published Jun 10, 2026

CVE-2026-46654Plonky3 MultiField32Challenger: transcript malleability and challenge entropy loss

Updated under an hour ago ()

Does this affect you?

It affects Plonky3. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Plonky3 is a toolkit for polynomial IOPs (PIOPs). Prior to versions 0.4.3 and 0.5.3, an attacker controlling prover-side observations can craft distinct transcripts that produce identical challenges, breaking the binding property of Fiat-Shamir. This issue has been patched in versions 0.4.3 and 0.5.3.

CVSS
8.9 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N
Weakness (CWE)
CWE-1240, CWE-345
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jun 11, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Plonky3 Plonky3
plonky3:plonky3 (from the name)
before 0.4.3; from 0.5.0, < 0.5.3
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.