CVE-2026-46751Apache Kvrocks: Does not remove the unsafe loadstring function from its Lua sandbox, allowing a user who can run EVAL scripts to load crafted, unvalidated bytecode that crashes the server process, resulting in a remote denial of service.
Updated under an hour ago ()
Does this affect you?
It affects Apache Software Foundation Apache Kvrocks. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
A vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from 2.2.0 through 2.15.0. Users are recommended to upgrade to version 2.16.0, which fixes the issue.
- CVSS
- 5.5 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H/S:N/AU:Y/R:U/V:D/RE:L/U:Green
- Weakness (CWE)
- Not given
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- apache
- NVD analysis
- Deferred
- Record last updated
- Jun 25, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Apache Software Foundation Apache Kvrocks apache_software_foundation:apache_kvrocks (from the name) | from 2.2.0 through 2.15.0 | CNA record |
References
- https://lists.apache.org/thread/cjjk4gq1nkb7pooqc37gz0blvdkqgv5zvendor-advisory
- http://www.openwall.com/lists/oss-security/2026/06/25/3
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.