Back to CVE records
High 8.7Published Jun 11, 2026

CVE-2026-47181PenguinMod-BackendApi: NoSQL Injection in Password Reset Endpoint Allows Account Takeover

Updated under an hour ago ()

Does this affect you?

It affects PenguinMod-BackendApi. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

PenguinMod-BackendApi is the backend api for penguinmod. Prior to version 1.0.0, a NoSQL injection vulnerability in the password reset endpoint allows any authenticated user to change the password of an account, leading to full account takeover. An attacker only needs a registered account and a valid password reset token for their own account. This issue has been patched in version 1.0.0.

CVSS
8.7 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-20, CWE-943
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jun 15, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
PenguinMod PenguinMod-BackendApi
penguinmod:backendapi (from the name)
before 1.0.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.