CVE-2026-47339Apache APISIX: authz-casdoor incorrect session sharing
Updated under an hour ago ()
Does this affect you?
It affects Apache Software Foundation Apache APISIX and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
- CVSS
- 5.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
- Weakness (CWE)
- CWE-863
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- apache
- NVD analysis
- Analyzed
- Record last updated
- Jun 22, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Apache Software Foundation Apache APISIX apache_software_foundation:apache_apisix (from the name) | from 2.14.1 through 3.16.0 | CNA record |
apache apisix apache:apisix | from 2.14.1 before 3.17.0 | NVD |
References
- https://lists.apache.org/thread/lk4q5o855cocc7zq5wh1zlctfmcq6f76vendor-advisory, mailing-list
- http://www.openwall.com/lists/oss-security/2026/06/19/9third-party-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.