CVE-2026-48044Envoy Zstd Decompressor: Ratio Check at Wrong Loop Depth lead to memory explosion
Updated under an hour ago ()
Does this affect you?
It affects envoyproxy envoy. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Envoy is an open source edge and service proxy designed for cloud-native applications. From 1.23.0 until 1.35.11, 1.36.7, 1.37.3, and 1.38.1, a vulnerability has been identified in Envoy's zstd decompressor implementation (ZstdDecompressorImpl). When zstd decompression is enabled, processing a specially crafted, highly compressed zstd payload can lead to massive memory allocation. An attacker can exploit this to cause severe memory exhaustion, potentially resulting in an Out-Of-Memory (OOM) kill and Denial of Service (DoS) for the Envoy proxy. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
- CVSS
- 7.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weakness (CWE)
- CWE-409
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- GitHub_M
- NVD analysis
- Analyzed
- Record last updated
- Jun 26, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
envoyproxy envoy envoyproxy:envoy (from the name) | from 1.38.0, < 1.38.1; from 1.37.0, < 1.37.3; from 1.36.0, < 1.36.7; from 1.23.0, < 1.35.11 | CNA record |
envoyproxy envoy envoyproxy:envoy | from 1.23.0 before 1.35.13; from 1.36.0 before 1.36.9; from 1.37.0 before 1.37.5; from 1.38.0 before 1.38.3 | NVD |
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-m3p9-47wh-88wgx-refsource-confirm, mitigation, vendor-advisory, exploit
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.