Back to CVE records
High 7.5Published Jul 14, 2026

CVE-2026-48069@grpc/grps-js: An incoming malformed compressed message can cause a client or server crash

Updated under an hour ago ()

Does this affect you?

It affects grpc-node. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS
7.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness (CWE)
CWE-248
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jul 15, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
grpc grpc-node
grpc:node (from the name)
before 1.9.16; from 1.10.0, < 1.10.12; from 1.11.0, < 1.11.4; from 1.12.0, < 1.12.7; from 1.13.0, < 1.13.5; from 1.14.0, < 1.14.4
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.