Back to CVE records
Medium 5.3Published Jul 14, 2026

CVE-2026-48805Twig: Sandbox state regression in deprecated internal wrappers in `src/Resources/core.php`

Updated under an hour ago ()

Does this affect you?

It affects twigphp Twig and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.

CVSS
5.3 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-693
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jul 16, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
twigphp Twig
twigphp:twig (from the name)
before 3.27.0
CNA record
symfony twig
symfony:twig
before 3.27.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.