Back to CVE records
High 7.3Published Jul 6, 2026

CVE-2026-49042Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Camel and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

CVSS
7.3 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness (CWE)
CWE-20
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Jul 6, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Camel
apache_software_foundation:apache_camel (from the name)
from 4.8.0 through 4.18.2; from 4.19.0 through 4.20.0
CNA record
apache camel
apache:camel
from 4.8.0 before 4.18.3; from 4.19.0 before 4.21.0
NVD

References

  • vendor-advisory, patch
  • third-party-advisory

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.