Back to CVE records
High 8.1Published Jun 30, 2026

CVE-2026-49877Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache ActiveMQ and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Improper Authorization vulnerability in Apache ActiveMQ. An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

CVSS
8.1 HIGH (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness (CWE)
CWE-285
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Jun 30, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache ActiveMQ
apache_software_foundation:apache_activemq (from the name)
before 5.19.8; from 6.0.0 before 6.2.7
CNA record
apache activemq
apache:activemq
before 5.19.8; from 6.0.0 before 6.2.7
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.