Back to CVE records
High 7.4Published Jun 17, 2026

CVE-2026-52698WordPress PushEngage – Web Push Notifications, eCommerce Automation & Chat Widget plugin <= 4.2.3 - Sensitive Data Exposure vulnerability

Updated under an hour ago ()

Does this affect you?

It affects Syed Balkhi PushEngage – Web Push Notifications, eCommerce Automation &amp; Chat Widget. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Subscriber Sensitive Data Exposure in PushEngage – Web Push Notifications, eCommerce Automation &amp; Chat Widget <= 4.2.3 versions.

CVSS
7.4 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness (CWE)
CWE-201
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
Patchstack
NVD analysis
Deferred
Record last updated
Jun 17, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Syed Balkhi PushEngage – Web Push Notifications, eCommerce Automation &amp; Chat Widget
syed_balkhi:pushengage_web_push_notifications_ecommerce_automation_and_amp_chat_widget (from the name)
from n/a through 4.2.3; fixed at 4.2.4
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.