Back to CVE records
High 8.5Published Jun 24, 2026

CVE-2026-52797Gogs: Overwriting critical files results in a denial of service

Updated under an hour ago ()

Does this affect you?

It affects gogs. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Gogs is an open source self-hosted Git service. Prior to 0.14.0, as an authorized user, an intruder can dictate the value which is passed to the git diff command which, together with bypassing the filtering of the passed value, allows the user to bypass the target directory and write the result of the comparison to any arbitrary path. This vulnerability is fixed in 0.14.0.

CVSS
8.5 HIGH (v3.1, CNA)CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H
Weakness (CWE)
CWE-22
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jun 25, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
gogs gogs
gogs:gogs (from the name)
before 0.14.0
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.