Back to CVE records
High 7.3Published Jun 23, 2026

CVE-2026-54328Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts

Updated under an hour ago ()

Does this affect you?

It affects earendil-works pi. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.

CVSS
7.3 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-379
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jun 24, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
earendil-works pi
earendil_works:pi (from the name)
from 0.74.0, < 0.78.1
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.