Back to CVE records
Medium 6.9Published Jul 28, 2026

CVE-2026-54659Pagy I18n locale option is not validated before being used in a file path

Updated under an hour ago ()

Does this affect you?

It affects ddnexus pagy. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Pagy is agnostic pagination in plain Ruby. From 43.0.0 until 43.5.6, Pagy::I18n.locale= in gem/lib/pagy/modules/i18n/i18n.rb stored locale values verbatim and later used them as <locale>.yml path components, allowing untrusted params[:locale] values with absolute paths or ../ sequences to create a file existence and readability oracle for YAML files. This issue is fixed in version 43.5.6.

CVSS
6.9 MEDIUM (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-22, CWE-200
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jul 29, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
ddnexus pagy
ddnexus:pagy (from the name)
from 43.0.0, < 43.5.6
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.