Back to CVE records
High 7.1Published Jul 6, 2026

CVE-2026-55514vLLM denial of service via prompt embeds on M-RoPE models

Updated under an hour ago ()

Does this affect you?

It affects vllm-project vllm and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

CVSS
7.1 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-617
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Analyzed
Record last updated
Jul 6, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
vllm-project vllm
vllm_project:vllm (from the name)
from 0.12.0, < 0.24.0
CNA record
vllm vllm
vllm:vllm
from 0.12.0 before 0.24.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.