Back to CVE records
Critical 9.1Published Jul 14, 2026

CVE-2026-58319Apache Doris: Improper Authentication in Frontend HTTP API

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Doris and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Certain Apache Doris FE HTTP REST administrative APIs were accessible without proper authentication. An unauthenticated attacker with network access to the FE HTTP service could perform unauthorized administrative operations, potentially affecting cluster integrity and availability and leading to cluster instability or denial of service. This issue affects Apache Doris versions prior to 3.1.0. Users are advised to upgrade to Apache Doris 3.1.0 or later.

CVSS
9.1 CRITICAL (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Weakness (CWE)
CWE-306
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Jul 14, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Doris
apache_software_foundation:apache_doris (from the name)
from 2.1.0 before 3.1.0
CNA record
apache doris
apache:doris
before 3.1.0
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.