Back to CVE records
Low 2.1Published Jul 7, 2026

CVE-2026-59153Anki's local HTTP server does not sufficiently validate requests

Updated under an hour ago ()

Does this affect you?

It affects ankitects anki. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

CVSS
2.1 LOW (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Weakness (CWE)
CWE-346
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jul 8, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
ankitects anki
ankitects:anki (from the name)
before 25.09.3
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.