Back to CVE records
High 7.0Published Jul 8, 2026

CVE-2026-59948Composer: Arbitrary file write outside vendor via malicious transitive package name

Updated under an hour ago ()

Does this affect you?

It affects composer. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

CVSS
7.0 HIGH (v3.1, CNA)CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-22, CWE-787
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
GitHub_M
NVD analysis
Deferred
Record last updated
Jul 9, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
composer composer
composer:composer (from the name)
from 1.0, < 2.2.29; from 2.3.0, < 2.10.2
CNA record

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.