CVE-2026-62390Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
Updated under an hour ago ()
Does this affect you?
It affects Apache Software Foundation Apache Kylin and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.
- CVSS
- 9.8 CRITICAL (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weakness (CWE)
- CWE-89
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- apache
- NVD analysis
- Modified
- Record last updated
- Jul 14, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
Apache Software Foundation Apache Kylin apache_software_foundation:apache_kylin (from the name) | from 4 through 5.0.3 | CNA record |
apache kylin apache:kylin | from 4.0.0 before 5.0.4 | NVD |
References
- https://lists.apache.org/thread/zdrj93txvdjj07f88s43d2pcg2gomvjcvendor-advisory, mailing-list
- http://www.openwall.com/lists/oss-security/2026/07/14/4mailing-list, third-party-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.