Back to CVE records
Critical 9.8Published Jul 20, 2026

CVE-2026-63071Apache Syncope: RCE via Groovy Sandbox bypass

Updated under an hour ago ()

Does this affect you?

It affects Apache Software Foundation Apache Syncope and 1 other product. Add what you run to find out whether that includes you.

No exploitation reported and no EPSS estimate yet.

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by tightening the Groovy security sandbox.

CVSS
9.8 CRITICAL (v3.1, CISA ADP)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness (CWE)
CWE-653
Known exploited
Not in CISA's KEV catalog
EPSS (exploitation in the next 30 days)
Not loaded for this CVE
Assigned by
apache
NVD analysis
Analyzed
Record last updated
Jul 21, 2026
First seen by InfoSec Signals
Oct 9, 2026

Affected products

Affected products
Apache Software Foundation Apache Syncope
apache_software_foundation:apache_syncope (from the name)
from 3.0.0-M0 through 3.0.16; from 4.0.0-M0 through 4.0.6; from 4.1.0-M0 through 4.1.1
CNA record
apache syncope
apache:syncope
from 3.0.0 through 3.0.16; from 4.0.0 before 4.0.7; from 4.1.0 before 4.1.2
NVD

References

References

The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.

Your cookie choices
We use essential cookies to run this site, and, only with your consent, an advertising cookie from Google to measure whether our ads lead to sign-ups and subscriptions. See our for details.