CVE-2026-65591n8n before 1.123.64 Sanitizer Bypass Remote Code Execution
Updated under an hour ago ()
Does this affect you?
It affects n8n-io n8n and 1 other product. Add what you run to find out whether that includes you.
No exploitation reported and no EPSS estimate yet.
Do this next
Free account, 1 product
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
- CVSS
- 8.9 HIGH (v4.0, CNA)CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L
- Weakness (CWE)
- CWE-917
- Known exploited
- Not in CISA's KEV catalog
- EPSS (exploitation in the next 30 days)
- Not loaded for this CVE
- Assigned by
- VulnCheck
- NVD analysis
- Analyzed
- Record last updated
- Jul 22, 2026
- First seen by InfoSec Signals
- Oct 9, 2026
Affected products
n8n-io n8n n8n_io:n8n (from the name) | before 1.123.64; 1.123.64 not affected | CNA record |
n8n n8n n8n:n8n | before 1.123.64; before 1.123.64; from 2.0.0 before 2.29.8; from 2.0.0 before 2.29.8; 2.30.0; 2.30.0 | NVD |
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-pm35-fqvh-cq5gvendor-advisory, mitigation
- https://www.vulncheck.com/advisories/n8n-before-sanitizer-bypass-remote-code-executionthird-party-advisory
The CVE record on cve.org NVD's entry
The CVE record is authoritative. Products marked “from the name” were identified from the CNA's free-text names, not a CPE, and are matched less certainly. This product uses the NVD API but is not endorsed or certified by the NVD.